[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [udig-dev] Eclipse4 support for uDig

Hi,

Just a general rule for running on Linux.

If something does not behave are you expect you'd better first check
that you are running NOT running with SWT-GTK3!

@Jody suggest we enforce GTK2 in our Linux-Launch-Config using
"--launcher.GTK_version 2" as described at
http://help.eclipse.org/luna/index.jsp?topic=/org.eclipse.platform.doc.isv/reference/misc/runtime-options.html

@Andrea: You can switch to GTK2 for now by setting an Env-Variable
SWT_GTK3=0 for the time being.

Tom

On 13.08.14 10:03, andrea antonello wrote:
> Here we go! :-)
> 
>> I think I'll simply work on with your branch and if necessary create a
>> new branch from where you left of.
>>
>> Waiting for bug reports ;-)
> 
> be careful what you wish for :)
> 
> First off, nice work and thanks to the sponsors of it.
> 
> I gave it a quite good testride.
> 
> Biggest problem: it is based on the branch that uses geotools 9. This
> is really a pity, since this means that the Spatial Toolbox is not
> working at all.
> I am not sure if this has been a coordination problem, but it renders
> uDig 2 not releasable like that. Jody, I wonder how simple it would be
> to move in the changes done to migrate to the newer geotools?
> 
> Other issues:
> * on the newest ubuntu uDig doesn't startup and crashes due to some
> lib problems. This one can be solved by adding to the ini file:
> -Dorg.eclipse.swt.browser.DefaultType=mozilla
> Yes, it always has something to do with the browsers :-) but, yeah,
> the fix is simple
> * the info tool not working. I have no idea why, there is no error, it
> simply doesn't seem to react.
> * when using uDig for a while, on exit there are some exceptions
> popping up telling that IService.dispose has been called twice
> 
> All in all I think you are almost there. Most probably the geotools
> problem is the biggest here. Jody, Frank, what do you think?
> 
> Cheers,
> Andrea
> 
> 
> 
>>
>> Tom
>>
>> On 13.08.14 03:04, Jody Garnett wrote:
>>>
>>>
>>> Continuing on:
>>>
>>> 1. Made a local luna-support branch
>>> from https://github.com/BestSolution-at/uDig/tree/luna-support
>>> 2. Checked Readme.textile for any change to build instructions
>>> - description of branches do not match
>>> 3. mvn clean install -f pom-libs.xml
>>> - worked
>>> 4.  mvn clean install -Pproduct -Psdk -Pdocs
>>> - taking a long time, kind of expected as it downloads luna artifacts
>>> for the first time
>>> - failure building docs! Resolved by copying _static/udig.ico into
>>> user/en/udig.ico and devel/en/udig.ico I expect this is due to recent
>>> version of sphinx looking for icon before copying static files into
>>> position.
>>>
>>>
>>> Could not figure out how to issue a pull request to BestSolution-at
>>> repo, feel free to cherry pick changes
>>> from https://github.com/jodygarnett/udig/tree/luna-support (or I can set
>>> up a shared branch).
>>>
>>>
>>> _______________________________________________
>>> udig-dev mailing list
>>> udig-dev@xxxxxxxxxxxxxxxx
>>> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
>>> https://locationtech.org/mailman/listinfo/udig-dev
>>>
>>
>> _______________________________________________
>> udig-dev mailing list
>> udig-dev@xxxxxxxxxxxxxxxx
>> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
>> https://locationtech.org/mailman/listinfo/udig-dev
> _______________________________________________
> udig-dev mailing list
> udig-dev@xxxxxxxxxxxxxxxx
> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
> https://locationtech.org/mailman/listinfo/udig-dev
>